Could not load "plugins/AdminShop"

Discussion in 'Plugin Development' started by Emphytos, Mar 18, 2012.

  1. Offline

    Emphytos

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Hi,

    I create the plugin AdminShop, players can sell their items with sign.

    On my local server I don't have any error, but on my debian server, I've this error:
    Code:
    [LIST=1]
    [*]17:11:09 [SEVERE] Could not load 'plugins/AdminShop.jar' in folder 'plugins'
    [*]org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: fr/emphytos/adminshop/AdminShop : Unsupported major.minor version 51.0
    [*]        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:150)
    [*]        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:287)
    [*]        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:211)
    [*]        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:207)
    [*]        at org.bukkit.craftbukkit.CraftServer.reload(CraftServer.java:537)
    [*]        at org.bukkit.Bukkit.reload(Bukkit.java:182)
    [*]        at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:22)
    [*]        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:166)
    [*]        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:469)
    [*]        at org.bukkit.craftbukkit.CraftServer.dispatchServerCommand(CraftServer.java:465)
    [*]        at net.minecraft.server.MinecraftServer.b(MinecraftServer.java:599)
    [*]        at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:568)
    [*]        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:452)
    [*]        at net.minecraft.server.ThreadServerApplication.run(SourceFile:490)
    [*]Caused by: java.lang.UnsupportedClassVersionError: fr/emphytos/adminshop/AdminShop : Unsupported major.minor version 51.0
    [*]        at java.lang.ClassLoader.defineClass1(Native Method)
    [*]        at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
    [*]        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    [*]        at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
    [*]        at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
    [*]        at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
    [*]        at java.security.AccessController.doPrivileged(Native Method)
    [*]        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
    [*]        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:41)
    [*]        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:29)
    [*]        at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
    [*]        at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
    [*]        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:334)
    [*]        at java.lang.Class.forName0(Native Method)
    [*]        at java.lang.Class.forName(Class.java:264)
    [*]        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:139)
    [*]        ... 13 more
    [/LIST]
    
    I really don't know why I've this error, my others plugins work !

    Thanks
  2. Offline

    dsmyth1915

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Your running the server in a Java 7 environment. Try running it in a JRE6
  3. Offline

    kumpelblase2

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    it's not because of the server, it's because he's using java 7 to build the plugin.

Share This Page