"Perhaps a server is already running on this port" - Help Me :)

Discussion in 'Bukkit Help' started by lewisj45, Jan 21, 2012.

  1. Offline

    lewisj45

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Hey ! I made a server working fine then i was messing around and i deleted it by accident..
    so i made the server again and when i click the "server.command" to run the server i get this message : "Perhaps a server is already running on this port" ! I am NOT using hamachi if that helps :)
  2. Offline

    Chrisward

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Restart, see how it goes
  3. Offline

    Tyler_Tsero

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Go into task manager and stop all java.exe applications (java.exe, javaw.exe, jusched.exe).

    restart server.
    And then it should run properly again

    This post has been edited 1 time. It was last edited by Tyler_Tsero Jan 21, 2012.
  4. Offline

    lewisj45

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I stopped the script and clicked it again and it said the same thing :(!
  5. Offline

    lewisj45

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Im on mac :L So i don't have task manger!
  6. Offline

    JWhy

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Restart the whole computer
    Chrisward likes this.
  7. Offline

    Chrisward

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Exactly what I meant :p
  8. Offline

    JWhy

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Terminal
    /agree :D
  9. Offline

    lewisj45

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Nothing happened
  10. Offline

    JWhy

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Then set the port to something but 25565
  11. Offline

    lewisj45

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    The port is 25565 :)
  12. Offline

    Royalgamer06

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Close all java processes. LEAVE server-IP= in the server.properties BLANK! Your friends can join with your IP (http://whatsyourip.com/) and you can connect with the IP; localhost:25565 (or with an other port you use).
    NOTE: you must have port forwarded! Don't know how? Search on the internet, there are many tutorials!
    poperdie likes this.
  13. Offline

    salik12

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I'm on mac too.just go to activity monitor, then find java.then quit process.you can find it in spotlight. hope i helped!
    Deren909 likes this.
  14. Offline

    Jayash

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I'm on mac too and I really need help. I made a sever but I can't build on it can someone help me? I tried to make the server again but it says,
    Perhaps a server is already running on that port?
    So I have two problems, maybe someone can help me?
    I'm on Mac.
    Thanks!!! [fire][diamond][creeper][gold][diamondblock]:)
  15. Offline

    Delocaz

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    People can be seriously retarded something.

    1. Are you OP? Did you remove the shitty built-in spawn protection in bukkit.yml?

    2. That message should explain anything you need to know, close the other server goddammit.
  16. Offline

    jedi_nipl

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Im on a mac and I just finally made a server but when i try to go on it, it says

    [INFO] Starting minecraft server version 1.2.4
    18:19:57 [INFO] Loading properties
    18:19:57 [INFO] Starting Minecraft server on *************:25565
    18:19:57 [WARNING] **** FAILED TO BIND TO PORT!
    18:19:57 [WARNING] The exception was: java.net.BindException: Can't assign requested address
    18:19:57 [WARNING] Perhaps a server is already running on that port?
    HELP!!!!

    This post has been edited 1 time. It was last edited by jedi_nipl Apr 2, 2012.
  17. Offline

    Chrisward

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    @jedi_nipl, remove the censoring. Don't worry, we won't hack you, just need to know what it is
    stuntguy3000 likes this.
  18. Offline

    Chrisward

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Actually scratch that, set the server-ip back to it's default setting of nothing. Should fix it
    Code:
    server-ip=
  19. Offline

    PlayinCOD2132

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Ok what you need to do is this change your port from 25565 from 65534 here is a example

    #Minecraft server properties
    #*************************
    allow-nether=true
    level-name=*****
    enable-query=false
    allow-flight=false
    server-port=65534 <----------------------------------------------------- THIS RIGHT HERE NEEDS TO BE CHANGED!
    level-type=DEFAULT
    enable-rcon=false
    level-seed=
    server-ip=************
    max-build-height=256
    spawn-npcs=true
    white-list=false
    spawn-animals=true
    snooper-enabled=true
    texture-pack=
    online-mode=false
    pvp=true
    difficulty=1
    gamemode=0
    max-players=20
    spawn-monsters=true
    generate-structures=true
    view-distance=10
    motd=**************
    [diamond] [IMG] [IMG] [IMG] [IMG] [IMG] [IMG]

    This post has been edited 1 time. It was last edited by PlayinCOD2132 Aug 8, 2012.
  20. Offline

    Chrisward

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Why in gods name did you revive a 4 month dead thread?
  21. Offline

    Erik Malm

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    All of you guys really helped me, so I wanted to thank you all very much. I changed the server port and now mine is working. Thank you!

Share This Page