Permissions.yml

Discussion in 'Bukkit Help' started by Kraxxi, Apr 14, 2011.

  1. Offline

    Kraxxi

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Hey I am kinda new to this stuff, my server is running smoothly but I just can't get my head around the Permissions plugin, when I check it with the online parser it displays an error, and sometimes errors occur in the console as well.


    Code:
    # System is no longer used, but may become used in the future
    # Copies is for multiple-world support
    #   Put the name of the world you wish for it to be a clone of, otherwise leave it empty.
    #   If this file is for your default world (the one in server.properties) then you must
    #   leave copies blank.
    #  Example: copies: Derp    -  This will clone the permissions of the world Derp
    #
    # Make sure to rename this file to the name of the world that is in sever.properties under
    # level-name.  So if it is level-name: world  then this should be world.yml and in the
    # plugins/Permissions directory (ie. plugins/Permissions/world.yml)
    #
    # NOTE: Do not use tabs while editing this document.  Use only spaces.  A good way to avoid
    # doing this is to use Notepad++ and replace the tab with 4 spaces.
    plugin:
        permissions:
            system: default
            copies:
    
    ##
    # AntiBuild is included with this.  To disable a group from being able to build then
    # set the build: flag to false (build: false).  If you want a group to be able to build
    # then set it to true.
    ##
    # Groups can contain inheritance.
    #   To make a group inherit the permissions from another
    #   group simply place the groups name in the "inheritance:" like so:
    #
    #   Example:
    #       inheritance:
    #           - Default
    ##
    #   All permissions including the asterisks must be placed in single quotes.
    #   like so:
    #
    #       - 'foo.bar'
    #
    #   Otherwise errors will happen!
    ##
    #   Globalized Permission settings:
    #
    #       If a permission contains periods (.) you can denote a globalized parameter:
    #
    #           - 'foo.*'
    #
    #       This will allow you to use all general commands.
    #
    ##
    #   Single Asterisk denotes all commands:
    #
    #       - '*'
    #   If you give a group this permissions, do not have the group inherit any permissions
    #   from other groups.  Any users assigned to this group should NOT be given any additional
    #   permissions either.
    ##
    #   To exempt a node use the - prefix like so:
    #       - '-foo.bar'
    ##
    #   prefix: and suffix: do not do anything on their own.  You need another outside plugin
    #   such as iChat or HeroChat in order for these to do anything.
    groups:
        Default:
            default: true
            info:
                prefix: ''
                suffix: ''
                build: false
            inheritance:
            permissions:
                - 'foo.bar'
        Builder:
            default: false
            info:
                prefix: ''
                suffix: ''
                build: true
            permissions:
                - 'warpz0r.free.sethome'
                - 'warpz0r.free.home'
                - 'lavasurvival.play'
                - 'localshops.buysell'
                - 'mcmmo.skills.*'
                - 'mcmmo.regeneration'
                - 'mcmmo.commands.ability'
                - 'mcmmo.commands.ptp'
                - 'mcmmo.commands.party'
                - 'mcmmo.chat.partychat'
                - 'herolock.chest.lock'
                - 'herolock.chest.unlock'
                - 'herolock.chest.change'
            - 'warpz0r.sethome'
                - 'warpz0r.home'
                - 'warpz0r.worldhome'
        Coolbuilder
            default: false
            info:
                prefix: ''
                suffix: ''
                build: true
            inheritance
                - Builder
            permissions:
                   - 'warpz0r.sethome'
            - 'warpz0r.home'
            - 'warpz0r.worldhome'
        Moderator:
            default: false
            info:
                prefix: ''
                suffix: ''
                build: true
            inheritance:
                - Coolbuilder
                - Builder
            permissions:
                - 'lavasurvival.host'
                - 'bedrockcontrol.getdrop'
                - 'multiverse.tp'
                - 'instabreak.toggle'
                - 'instabreak.force'
                - 'warpz0r.sethome'
                - 'warpz0r.home'
                - 'warpz0r.worldhome'
        Admins:
            default: false
            info:
                prefix: 'Deimudda'
                suffix: ''
                build: true
            inheritance:
            permissions:
                - '*'
    
    ##
    # Users denote which users are included in which group.
    # TheNo1Yeti is in the Admin group
    # Herpina is a member of the Moderator group but also has access
    # to the herp.derp permissions
    # Derpina is a member of the admin group but does not have access
    # to the derp.derp permission node
    # Users can also have a prefix and suffix as seen with Herpina
    ##
    users:
        Kraxxi:
            group: Default
            permissions:
        xKizunEx:
            group: Coolbuilder
            permissions:
        Mauzel:
            group: Admins
            permissions:
        mctod:
            group: Admins
            permissions:
        Deppenkaiser:
            group: Moderator
            permissions:
        lueon92:
            group: Moderator
            permissions:
    Help on this would be much appreciated.
    Also just on a sidenote, is there a mod that enables me to switch between peaceful/normal via command?

    Cheers,
    Kraxxi
  2. Offline

    alucart93

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    there is one node error in here:
    Code:
        Coolbuilder
            default: false
            info:
                prefix: ''
                suffix: ''
                build: true
            inheritance
                - Builder
            permissions:
                   - 'warpz0r.sethome'
            - 'warpz0r.home'
            - 'warpz0r.worldhome'
    and one here:
    Code:
        Builder:
            default: false
            info:
                prefix: ''
                suffix: ''
                build: true
            permissions:
                - 'warpz0r.free.sethome'
                - 'warpz0r.free.home'
                - 'lavasurvival.play'
                - 'localshops.buysell'
                - 'mcmmo.skills.*'
                - 'mcmmo.regeneration'
                - 'mcmmo.commands.ability'
                - 'mcmmo.commands.ptp'
                - 'mcmmo.commands.party'
                - 'mcmmo.chat.partychat'
                - 'herolock.chest.lock'
                - 'herolock.chest.unlock'
                - 'herolock.chest.change'
            - 'warpz0r.sethome'
                - 'warpz0r.home'
                - 'warpz0r.worldhome'
    in the first one the - 'warpz0r.sethome' have to many nodes, about 6...
    and in the second its the : - 'warpz0r.sethome' 4 node more

    more errors i couldnĀ“t find
  3. Offline

    Andre_9796

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Will mean: - has to be under the first i in permissions.
  4. Offline

    Kraxxi

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    just checking, I think its fine like this:

    Code:
    # System is no longer used, but may become used in the future
    # Copies is for multiple-world support
    #   Put the name of the world you wish for it to be a clone of, otherwise leave it empty.
    #   If this file is for your default world (the one in server.properties) then you must
    #   leave copies blank.
    #  Example: copies: Derp    -  This will clone the permissions of the world Derp
    #
    # Make sure to rename this file to the name of the world that is in sever.properties under
    # level-name.  So if it is level-name: world  then this should be world.yml and in the
    # plugins/Permissions directory (ie. plugins/Permissions/world.yml)
    #
    # NOTE: Do not use tabs while editing this document.  Use only spaces.  A good way to avoid
    # doing this is to use Notepad++ and replace the tab with 4 spaces.
    plugin:
        permissions:
            system: default
            copies:
    
    ##
    # AntiBuild is included with this.  To disable a group from being able to build then
    # set the build: flag to false (build: false).  If you want a group to be able to build
    # then set it to true.
    ##
    # Groups can contain inheritance.
    #   To make a group inherit the permissions from another
    #   group simply place the groups name in the "inheritance:" like so:
    #
    #   Example:
    #       inheritance:
    #           - Default
    ##
    #   All permissions including the asterisks must be placed in single quotes.
    #   like so:
    #
    #       - 'foo.bar'
    #
    #   Otherwise errors will happen!
    ##
    #   Globalized Permission settings:
    #
    #       If a permission contains periods (.) you can denote a globalized parameter:
    #
    #           - 'foo.*'
    #
    #       This will allow you to use all general commands.
    #
    ##
    #   Single Asterisk denotes all commands:
    #
    #       - '*'
    #   If you give a group this permissions, do not have the group inherit any permissions
    #   from other groups.  Any users assigned to this group should NOT be given any additional
    #   permissions either.
    ##
    #   To exempt a node use the - prefix like so:
    #       - '-foo.bar'
    ##
    #   prefix: and suffix: do not do anything on their own.  You need another outside plugin
    #   such as iChat or HeroChat in order for these to do anything.
    groups:
        Default:
            default: true
            info:
                prefix: ''
                suffix: ''
                build: false
            inheritance:
            permissions:
                - 'foo.bar'
        Builder:
            default: false
            info:
                prefix: ''
                suffix: ''
                build: true
            permissions:
                - 'warpz0r.free.sethome'
                - 'warpz0r.free.home'
                - 'lavasurvival.play'
                - 'localshops.buysell'
                - 'mcmmo.skills.*'
                - 'mcmmo.regeneration'
                - 'mcmmo.commands.ability'
                - 'mcmmo.commands.ptp'
                - 'mcmmo.commands.party'
                - 'mcmmo.chat.partychat'
                - 'herolock.chest.lock'
                - 'herolock.chest.unlock'
                - 'herolock.chest.change'
                - 'warpz0r.sethome'
                - 'warpz0r.home'
                - 'warpz0r.worldhome'
            Coolbuilder:
            default: false
            info:
                prefix: ''
                suffix: ''
                build: true
            inheritance:
                - Builder
            permissions:
                - 'warpz0r.sethome'
                - 'warpz0r.home'
                - 'warpz0r.worldhome'
        Moderator:
            default: false
            info:
                prefix: ''
                suffix: ''
                build: true
            inheritance:
                - Coolbuilder
                - Builder
            permissions:
                - 'lavasurvival.host'
                - 'bedrockcontrol.getdrop'
                - 'multiverse.tp'
                - 'instabreak.toggle'
                - 'instabreak.force'
                - 'warpz0r.sethome'
                - 'warpz0r.home'
                - 'warpz0r.worldhome'
        Admins:
            default: false
            info:
                prefix: 'Deimudda'
                suffix: ''
                build: true
            inheritance:
            permissions:
                - '*'
    
    ##
    # Users denote which users are included in which group.
    # TheNo1Yeti is in the Admin group
    # Herpina is a member of the Moderator group but also has access
    # to the herp.derp permissions
    # Derpina is a member of the admin group but does not have access
    # to the derp.derp permission node
    # Users can also have a prefix and suffix as seen with Herpina
    ##
    users:
        Kraxxi:
            group: Default
            permissions:
        xKizunEx:
            group: Coolbuilder
            permissions:
        Mauzel:
            group: Admins
            permissions:
        mctod:
            group: Admins
            permissions:
        Deppenkaiser:
            group: Moderator
            permissions:
        lueon92:
            group: Moderator
            permissions:
    EDIT:

    Appearently, now nobody on this server has any permissions, no matter what group I add them to they just cant build or use any commands. Even admins can only dig away blocks
  5. Offline

    kakashi

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    how dit you name your permissions file?
  6. Offline

    Andre_9796

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    as @kakashi said, the permssions config has to match the name of your world folder. rename it to {worldname}.yml
  7. Offline

    Kraxxi

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    yeah i know that, its named 'world' :p

    It also seems to overwrite the op's file, which I wouldnt mind if it worked properly.
    I have to insert an error into the code so other people can build for some reason.
  8. Offline

    Kraxxi

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    no ideas? anyone?

Share This Page