WorldGuard Admin Node! (worldguard.* or worldguard.admin) Don't Work!

Discussion in 'Bukkit Help' started by BoxedKian, Nov 18, 2011.

  1. Offline

    BoxedKian

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Hey Guys. Title basically says it all. I have a Server and I'm trying to give a fellow Staff member all access to WorldGuard. I already gave him WorldEdit Wand and Position Selecting.

    He needs to get WorldGuard Admin.

    worldguard.*

    or

    worldguard.admin

    Doesn't work.

    EDIT: PermissionsBukkit doesn't support the .* Wild Card apparently. How do I give him WorldGuard Admin Access without every single node...?

    This post has been edited 1 time. It was last edited by BoxedKian Nov 18, 2011.
  2. Online

    c0mp 13371331337 Moderator

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Which Permissions plugin are you using?

    This post has been edited 1 time. It was last edited by c0mp Nov 18, 2011.
  3. Offline

    BoxedKian

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I just Edit'd the topic. Read the "EDIT:"
  4. Offline

    shadrxninga

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Have you installed the SuperPerms bridge? This would allow the .* to work, also you could change permissions plugins - I know for a fact that PermissionEX allows this.
  5. Offline

    BoxedKian

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I currently own a fairly big Server and the last thing I want to do is re-do permissions. Your telling me that all is do is install this JAR for the Bridge. Nothing else happens. Nodes don't change. Permissions in McMyAdmin don't reset or change either?
  6. Offline

    shadrxninga

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I understand, changing permission is a hassle! But, Yes! Just drop this jar into your plugins folder and in theory it should work, it will not change any permission you already have. It will just enable the * wildcard functionality - which is what you need to fix your problem.
  7. Offline

    BoxedKian

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Yeah... turns out we already have the bridge yet worldguard.* still won't work!
  8. Offline

    shadrxninga

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Have you updated the Super-Perms bridge to the latest version?

    This post has been edited 1 time. It was last edited by shadrxninga Nov 18, 2011.
  9. Online

    c0mp 13371331337 Moderator

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    PermissionsBukkit SORTA supports the .* wildcard nodes, but only if the plugin defines the .* nodes. WorldEdit/WorldGuard claims support this, according to the documentation, and it works fine on my server with PermissionsBukkit:
    Code:
        Moderator:
    
            permissions:
                -SNIP-
                worldedit.*: true
                worldguard.*: true
    If you wanna pastebin your plugins/PermissionsBukkit/config.yml file and a startup log we can have a look and see why it's not working for you.
  10. Offline

    BoxedKian

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    We've been working on this for hours via McMyAdmin and FTP yet nothing is working. We are practically losing hope.
  11. Offline

    BoxedKian

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Yes we have, Updated, Rebooted and all. Many times.

Share This Page