Default Spawn

Discussion in 'Bukkit Help' started by Sigong, Oct 30, 2012.

  1. Offline

    Sigong

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I recently made a new world. This world is just a normal world. I removed the old world (I still have it, its just not on the server). I want players to spawn in a different world. I've used /setspawn and /mv setspawn in the world where I want them to spawn. New players still spawn in the default spawnpoint of the normal world. But when someone type s in /spawn, they go to the place where I want them to. So to recap, new players spawn in the wrong place (default spawn), /spawn teleports them to the right place. The only plugins that I am pretty sure control this are: essentials, multiverse, and maybe worldguard? Thanks in advance!
  2. Offline

    Sigong

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    bumping this I really need help. this needs to be fixed for the grand reopening tomorrow
  3. Offline

    Necrodoom

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    did you set a newbie spawn using /setspawn newbies? if yes, set it to new spawn.
  4. Offline

    Sigong

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I did that.
    do I have to set it to that in the config also?
  5. Offline

    Sigong

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    BTW this was working before, I think it was the new world that screwed it up
  6. Offline

    GRPGamer

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Do you have permissions?
  7. Offline

    Sigong

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    yes i do. groupmanager
  8. Offline

    Necrodoom

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    PLEASE use the edit button instead of double posting.
    and yes, if you do /setspawn newbies, config needs to be set to that before anything.
  9. Offline

    Sigong

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME


    so at the bottom of the essentials config, the default spawnpoint should be set to "newbies"
    should the respawning thing be set to normal, high, or low?
    I just want to have one spawnpoint for everything, including dying, /spawn, and first joining.

    This post has been edited 2 times. It was last edited by Sigong Oct 30, 2012.
  10. Offline

    GRPGamer

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Beat me to it :/
  11. Offline

    Sigong

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    so at the bottom of the essentials config, the default spawnpoint should be set to "newbies"
    should the respawning thing be set to normal, high, or low?
    I just want to have one spawnpoint for everything, including dying, /spawn, and first joining.
  12. Offline

    Necrodoom

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    high = overrides multiverse
    under high = multiverse overrides essentialssapwn
  13. Offline

    Sigong

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    But What should I have it set to to just have one spawn point.
  14. Offline

    Necrodoom

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    keep it as it is. if /setspawn newbies doesnt fix spawn, then try highest. if still not, you have another plugin that overrides spawn.
    do you use authme or xauth?

    This post has been edited 1 time. It was last edited by necrodoom Oct 30, 2012.
  15. Offline

    caucow

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I know that this is somewhere close to VERY late, but I have been getting the same problem and after this have a few things to say.

    First, I am using essentials (cuz itz just dat awsum), authme (since I want a server that my friends who haven't payed can get on), PermissionsEX (for my perms plugin, I find gm to be too buggy), and a number of other plugins.

    Second, necrodoom, stop being confusing, get to the point, actually answer the question, and be specific.

    Third, I understand what is going on and solved the problem on my server. I have a few different spawnpoints for different groups on my server and used "/setspawn member" (essentials) to set a spawnpoint for my default group (aka "member"). Before reading this page I had people spawning all over the place and many ending up in my donator shop able to buy stuff they shouldn't be able to and going around the server with god crap killing everyone and everything. After reading this page I went into my essentials configuration, and changed these lines:
    Code:
    newbies:
     
      # -=- A few lines of other stuff were here -=-
     
      # When we spawn for the first time, which spawnpoint do we use?
      # Set to "none" if you want to use the spawn point of the world.
      spawnpoint: none
    to the following:
    Code:
    newbies:
      # When we spawn for the first time, which spawnpoint do we use?
      # Set to "none" if you want to use the spawn point of the world.
      spawnpoint: member
    because "the spawn point of the world." means minecraft/bukkit's default spawnpoint handler. The default handler teleports the user to either a random location within 8 to 16 blocks with a block under it, or (if that is too dangerous [meaning there is either lava or void there], i think the next part applies) the nearest safe place with a block under it (radius undefined).

    Now I have people spawning at the location I used /setspawn even when they join the server for the first time.
    Note: You don't have to set the " 'settings:' -> 'restrictions:' -> 'teleportUnAuthedToSpawn:' " line in the AuthMe config to "true" for this to work. I specifically didn't want to so I could teleport to them if they decide to sign out because they aren't following the rules and don't want to get caught. (Yes this actually happens and actually is very common.)
    Note: If you do use essentials in this way, people will be teleported to the exact same spot even if a troll comes and fills it with lava, solid blocks or makes a hole to the void.

    This post has been edited 3 times. It was last edited by caucow May 4, 2013.

Share This Page