Essentials Chat/GroupManager HELP

Discussion in 'Bukkit Help' started by Bruno1574, Sep 3, 2012.

  1. Offline

    Bruno1574

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Could anyone help me by setting some groups in group manager to have colors without always going "&2 test" Is there anyway i can add the chat colors to certain groups that will automatically say a message in lets say green and they didn't type in the &2!!!
    Please i need help!!!!
    I'm just posting my Admin group for group manager

    Admin:
    default: false
    permissions:
    - lottery.admin.draw
    - lottery.admin.addtopot
    - citizens.admin
    inheritance:
    - moderator
    info:
    prefix: '&4[Admin]&f '
    build: true
    suffix: ''

    so how do i add color to the Admin's chat without them always going &2 etc.
    P.S. Sorry, i don't know how to properly post stuff from YAML files to here :L

    This post has been edited 1 time. It was last edited by TnT Sep 3, 2012.
  2. Offline

    JamiePhonic

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    the chunk of the config you posted should work. thats what i use and it works fine.
  3. Offline

    Bruno1574

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    What config you mean that one up there? ^
  4. Offline

    JamiePhonic

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    yes. that config
  5. Offline

    Bruno1574

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Yeah it works the prefix and all with color but i mean the color of the message that is sent in chat
  6. Offline

    JamiePhonic

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    so you want:
    [admin] (JamiePhonic): hello all!
  7. Offline

    Bruno1574

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Kinda, i got the user name and prefix good just the message in chat so yes
  8. Offline

    JamiePhonic

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    that is handled by essentials. i recommend removing the prefixes from group manager and letting essentials cha handle it all
    in your essentials config.yml, go to line 433. youll come to the essentials chat config. use this instead
    Code:
    ############################################################
    # +------------------------------------------------------+ #
    # |                  EssentialsChat                    | #
    # +------------------------------------------------------+ #
    ############################################################
     
    chat:
     
      # If EssentialsChat is installed, this will define how far a player's voice travels, in blocks.  Set to 0 to make all chat global.
      # Note that users with the "essentials.chat.spy" permission will hear everything, regardless of this setting.
      # Users with essentials.chat.shout can override this by prefixing text with an exclamation mark (!)
      # Or with essentials.chat.question can override this by prefixing text with a question mark (?)
      # You can add command costs for shout/question by adding chat-shout and chat-question to the command costs section."
      radius: 0
     
      # Chat formatting can be done in two ways, you can either define a standard format for all chat
      # Or you can give a group specific chat format, to give some extra variation.
      # If set to the default chat format which "should" be compatible with ichat.
      # For more information of chat formatting, check out the wiki: http://ess.khhq.net/wiki/Chat_Formatting 
     
      #format: '{DISPLAYNAME}: {MESSAGE}'
      #format: '&7[{GROUP}]&f {DISPLAYNAME}&7:&f {MESSAGE}'
     
      group-formats:
        Default: '&e[{GROUP}]&7 {DISPLAYNAME}:&f {MESSAGE}'
        Builder: '&2[{GROUP}]&7 {DISPLAYNAME}:&f {MESSAGE}'
        Moderator: '&5[{GROUP}]&7 {DISPLAYNAME}:&f {MESSAGE}'
        Admins: '&c[{GROUP}]&7 {DISPLAYNAME}:&f {MESSAGE}'
        Owner: '&4[{GROUP}]&7 {DISPLAYNAME}:&f {MESSAGE}'
     
      # If your using group formats make sure to remove the '#' to allow the setting to be read.
    in the group formats part, change the group (admin moderator owner and so on.) to the groups you have.
    change the colour codes to suit. in the example above, change &f to what ever colour you want that groups chat to appear as.
  9. Offline

    Bruno1574

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Should i edit the [{GROUP}] stuff?
  10. Offline

    JamiePhonic

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    no.where it says:
    Default: '&e[{GROUP}]&7 {DISPLAYNAME}:&f {MESSAGE}'
    edit only the golour codes and the group at the start to match your groups config

    e.g. if you have noob as a group instead of default, then it would be:
    noob: '&e[{GROUP}]&7 {DISPLAYNAME}:&f {MESSAGE}'
  11. Offline

    Bruno1574

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    This is what i have for the Owner
    Owner: '&2[{GROUP}]&7 {DISPLAYNAME}:&6 {MESSAGE}'
    but for the &6 message does not work, nor the prefix when you told me to remove it from GM, It's still my plain name and white message. Was there anything else i should have removed/disabled?
  12. Offline

    Necrodoom

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
  13. Offline

    Bruno1574

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
  14. Offline

    Necrodoom

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    i see no error with the indenting, are you using right version for bukkit?
  15. Offline

    JamiePhonic

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    you must comment out the section
    Code:
     # Chat formatting can be done in two ways, you can either define a standard format for all chat
      # Or you can give a group specific chat format, to give some extra variation.
      # If set to the default chat format which "should" be compatible with ichat.
      # For more information of chat formatting, check out the wiki: http://ess.khhq.net/wiki/Chat_Formatting 
     
      # format: '<{DISPLAYNAME}> {MESSAGE}'    <<===comment this out with # sign
      # format: '&7[{GROUP}]&f {DISPLAYNAME}&7:&f {MESSAGE}' <<===comment this out too
     
      group-formats:
        Default: '{WORLDNAME} {DISPLAYNAME}&7:&f {MESSAGE}'
        Builder: '&6[{GROUP}]&f {DISPLAYNAME}:&f {MESSAGE}'
        Moderator: '&b[{GROUP}]&f {DISPLAYNAME}:&f {MESSAGE}'
        Admin: '&4[{GROUP}]&f {DISPLAYNAME}:&f {MESSAGE}'
        Owner: '&2[{GROUP}]&f {DISPLAYNAME}:&6 {MESSAGE}'
     
      # If your using group formats make sure to remove the '#' to allow the setting to be read.
    
  16. Offline

    Necrodoom

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    jamiephonic: its recommended that one format stays uncommented
  17. Offline

    JamiePhonic

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    the first 2 format lines are for general formatting, e.g. for servers without permissions or servers where all groups and chat text is shown in 1 colour.
    he wants per group formatting in this case.
    this is my config and it works fine.
    Code:
    # Chat formatting can be done in two ways, you can either define a standard format for all chat
      # Or you can give a group specific chat format, to give some extra variation.
      # If set to the default chat format which "should" be compatible with ichat.
      # For more information of chat formatting, check out the wiki: http://ess.khhq.net/wiki/Chat_Formatting
     
      #format: '{DISPLAYNAME}: {MESSAGE}'
      #format: '&7[{GROUP}]&f {DISPLAYNAME}&7:&f {MESSAGE}'
     
      group-formats:
        Default: '&e[{GROUP}]&7 {DISPLAYNAME}:&f {MESSAGE}'
        Builder: '&2[{GROUP}]&7 {DISPLAYNAME}:&f {MESSAGE}'
        Moderator: '&5[{GROUP}]&7 {DISPLAYNAME}:&f {MESSAGE}'
        Admins: '&c[{GROUP}]&7 {DISPLAYNAME}:&f {MESSAGE}'
        Owner: '&4[{GROUP}]&7 {DISPLAYNAME}:&f {MESSAGE}'
     
      # If your using group formats make sure to remove the '#' to allow the setting to be read.

    This post has been edited 1 time. It was last edited by JamiePhonic Sep 3, 2012.
  18. Offline

    Necrodoom

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    if group-format cant be detected, it falls back to format, though.
  19. Offline

    JamiePhonic

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    yes, but thats only if there are parsing errors. and essentials will simply switch to using no formatting if group-format cant be detected and format has been commented out. i know. its happened to me before. i just ended up with <Jamiephonic>: test
    instead of:
    (owner) JamiePhonic: test
  20. Offline

    zipron

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I only read your main post, so don't blame me if I didn't answer all possible offtopic stuff. If you want to set up permissions and you want to know what you're doing so you can do it in the future without any help, check one of my permissions guide:
    - YML with groupmanager
    - PEX <-- best
    both links are in my sig

    zip

    This post has been edited 1 time. It was last edited by zipron Sep 3, 2012.
  21. Offline

    BrandonFlude

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Can I get some help on a similar problem?! I have it configured right (i think) But it only comes up with my nickname, no prefix or coloured chat
  22. Offline

    JamiePhonic

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    post your config on pastebin (pastebin.com) or use the cod tags here.
  23. Offline

    zipron

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    oh please don't.. he won't learn a thing if someone else fixes it for him. Had a 12-year old boy yesterday having YML problems, after reading my guide he sent a mail saying thanks because now he understands it.. so it IS possible..
  24. Offline

    JamiePhonic

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    i was going to point out where the errors were, then sent him fix it himself
  25. Offline

    zipron

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    that's the same... just let him look for the errors himself.. prooved yesterday that it's possible =( this helps no one but lazy people becoming more lazy..
  26. Offline

    Jewtzu

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Not sure if this makes me look totally unexperienced, but im not completely running a server, im co-owner on one and i was wondering. Is it possible to manually add a group into the server without having the GroupManger files? Like by using the in-game /mangadd and then from there on adding prefixes. If so i have tried and it seems only my Name appears and not the title of the group. i.e **iBeast ~Dex thats my nick. Between the iBeast and my name is were the group name should be, yet its not there :/, Can anyone help?

    This post has been edited 1 time. It was last edited by Butkicker12 Sep 5, 2012.
  27. Offline

    BrandonFlude

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Sorry Guys, Necroddom helped me fix it, turned out I had an extra indentation.
  28. Offline

    Kaerei

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I'm actually having a couple of problems. One, is getting the groups to show the right color. Right now they all show grey, but the names show the right color.
    http://pastie.org/5649457

    Also, I'm having issues getting the groups to carry over to different worlds. I need for everyone to be in the same group, no matter what world they're in. But changing the group names, then changing the group they're in in PermissionsBukkit>Config.

    Am I missing something?

    This post has been edited 1 time. It was last edited by NuclearW Jan 8, 2013.
  29. Offline

    Necrodoom

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    1. you necroed a thread, you shouldve created a new one
    2. your group format lines indenting is wrong
    3. i dont use permissionsbukkit, cant help with that

Share This Page