How to disable fire spread, but NOT flint+tinder?

Discussion in 'Bukkit Help' started by Piginabag, Jun 27, 2013.

  1. Offline

    Piginabag

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Hello,

    I want the players on my server to be able to light nether portals, and set fire to blocks, but I don't want the fire to be able to spread. It appears simple to do this, and I've configured my plugins accordingly, but they still are unable to use flint+tinder.

    My plugins are: WorldEdit, NoCheatPlus, iConomy, Towny, CoreProtect, PermissionsEx, Modifyworld, TerrainControl, Questioner, WorldGuard, Essentials, dynmap, TownyChat, EssentialsSpawn, ChestShop

    Essentials looks like this:

    prevent:
    lava-flow: false
    water-flow: false
    water-bucket-flow: false
    fire-spread: true
    lava-fire-spread: false
    flint-fire: false

    WorldGuard looks like this:

    ignition:
    block-tnt: false
    block-tnt-block-damage: true
    block-lighter: false
    fire:
    disable-lava-fire-spread: true
    disable-all-fire-spread: true
    disable-fire-spread-blocks: []
    lava-spread-blocks: []
  2. Offline

    JamiePhonic

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    this should do the job. if its not, then have you restarted the server since making the changes?
  3. Offline

    Piginabag

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I have, and it's still not working. Players get a "you do not have sufficient permissions" type message, which makes me think it might be either permissionsex or maybe modifyworld that are preventing it? It seems like a permission issue.
  4. Offline

    Kolugo

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Do you have the "modifyworld.*" permissions node?

    your essentials config:
    Code:
    fire-spread: true
    lava-fire-spread: false
    flint-fire: false
    try changing fire-spread to false and flint-fire to true.
  5. Offline

    Necrodoom

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    remember its under a "prevent:"
  6. Offline

    Bobcat00

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I simply did:
    /gamerule doFireTick false
    (must be capitalized exactly as shown!)
    And left WorldGuard, etc, alone.

    This prevents fire spread (someone was buring down a jungle) and allows use of flint+steel. Note that fires will burn forever, unless you put them out.
  7. Offline

    Piginabag

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    By "leave worldguard etc alone", do you mean leave it at the settings I have, or disable all forms of fire protection?
  8. Offline

    Bobcat00

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I left all those settings at their defaults.
  9. Offline

    Piginabag

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Do you think you could paste in your worldguard/essentials fire settings? I still can't get it to work using your suggestion.
  10. Offline

    afistofirony

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    @Piginabag

    Code:
    ignition:
        block-tnt: false
        block-tnt-block-damage: true
        block-lighter: false
    fire:
        disable-lava-fire-spread: false
        disable-all-fire-spread: false
        disable-fire-spread-blocks: []
        lava-spread-blocks: []
    In game, just type the command below (exactly as shown)
    Code:
    /gamerule doFireTick false
    EDIT: Also, you may run into some issues running EssentialsProtect and WorldGuard at the same time.

    This post has been edited 1 time. It was last edited by afistofirony Jun 27, 2013.
  11. Offline

    Bobcat00

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I don't use Essentials Protect.

    WorldGuard config:
    Code:
    ignition:
        block-tnt: false
        block-tnt-block-damage: false
        block-lighter: false
    fire:
        disable-lava-fire-spread: true
        disable-all-fire-spread: false
        disable-fire-spread-blocks: []
        lava-spread-blocks: []
    
    The fires burning after a lightning strike is annoying (in that they never go out). I see there's a disable-lightning-strike-fire, so maybe I'll turn that on.
  12. Offline

    Piginabag

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    This has been an ongoing issue that I don't know how to fix. I've tried everything I could think of and am beyond frustrated that I cannot enable fire for players. They can't even light nether portals.
    Could someone take a look at my config?
  13. Offline

    Necrodoom

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    being an ancient thread, please repost the message they get along with the plugin list and worldguard/essentials config pastes.

Share This Page