Mob spawn rate so low

Discussion in 'Bukkit Help' started by zipron, Apr 14, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    zipron

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    The fifth topic I make about mob spawn rates in a few months anyways, here we go:

    specs:
    craftbukkit 1.2.5-R1.0
    server.properties:
    Code:
    #Minecraft server properties
     
    #Tue Mar 06 15:38:24 CET 2012
    allow-nether=true
    level-name=world
    enable-query=false
    allow-flight=false
    server-port=25565
    level-type=DEFAULT
    enable-rcon=false
    level-seed=
    server-ip=
    max-build-height=256
    spawn-npcs=true
    white-list=true
    spawn-animals=true
    online-mode=false
    pvp=true
    difficulty=3
    server-name=Unknown Server
    gamemode=0
    max-players=40
    spawn-monsters=true
    view-distance=5
    generate-structures=true
    motd=Zipron's MC
     
    
    plugins:
    - mcmmo
    - touchrestore
    - worldedit

    things I tried
    - I've made a mob sky spawner on singleplayer creative flatlands. (for those unfamiliar with this: it's a spawner of four pads in the sky at the height limit, so mobs don't spawn on the ground but only in your spawner, acts like a void spawner). It gave me 40 mobs after 3 minutes. So I decided to test it on my server: 0 spawns after waiting afk for 10 minutes.
    - I decided to import the map I've made in creative SP, it spawned some mobs, but way less than in singleplayer (the exact same map)
    - I disabled all my plugins (worldedit, TouchRestore and mcMMo), no difference
    - I created an underground basic mob farm in multiplayer, spawned 3 mobs after waiting 2 hours (they actually spawned in the first five minutes, no other mobs were spawned after it), in singleplayer it spawned a good amount of mobs
    - tried other difficulties (1-2-3 in properties file, didn't help)
    - tried /butcher, didn't help
    - tried the latest bukkit dev build, didn't help
    - I used to have a plugin which allowed me to configure mob limits in beta, this worked actually very nice, however I don't know any plugins (nolagg maybe) who does that, but it doesn't seems legit to me that I need to use a plugin to have the same effect I have on singleplayer.

    conclusion: my mob farms work in singleplayer, they don't in multiplayer on a clean bukkit install with the RB or dev build. I saw I don't know how many help topics about poor mob spawns. I don't know what to try now anymore, maybe it is coded in to prevent mob farming. Anyways, I like mob farming and I like exploring minecraft mechanics. That's why I post this (again) in the hope someone can help or knows a solution.

    if anyone knows a way to increase mob spawn rates by 500% with plugins, I would appreciate if you tell me what class and method it uses, so I can make a plugin and hope that fix some problems.

    @TnT
    @EvilSeph
    @ChrizC
    @Dinnerbone
    (does anyone knows other dev members?)

    Thanks,
    zipron
  2. Offline

    andrewpo

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    If you have essentials, can you give me the output of the " gc " command?

    Also your system specs & the start script you use to run bukkit.

    This post has been edited 1 time. It was last edited by andrewpo Apr 14, 2012.
  3. Offline

    zipron

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    specs:
    Code:
    MemTotal:        2054928 kB
     
    processor       : 0
    vendor_id       : GenuineIntel
    cpu family      : 15
    model           : 4
    model name      : Intel(R) Pentium(R) D CPU 3.00GHz
    stepping        : 4
    cpu MHz         : 2800.000
    cache size      : 1024 KB
    physical id     : 0
    siblings        : 2
    core id         : 0
    cpu cores       : 2
    apicid          : 0
    initial apicid  : 0
    fpu             : yes
    fpu_exception   : yes
    cpuid level     : 5
    wp              : yes
    flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc pebs bts nopl pni dtes64
    monitor ds_cpl est cid cx16 xtpr
    bogomips        : 5998.61
    clflush size    : 64
    cache_alignment : 128
    address sizes   : 36 bits physical, 48 bits virtual
    power management:
     
    processor       : 1
    vendor_id       : GenuineIntel
    cpu family      : 15
    model           : 4
    model name      : Intel(R) Pentium(R) D CPU 3.00GHz
    stepping        : 4
    cpu MHz         : 2800.000
    cache size      : 1024 KB
    physical id     : 0
    siblings        : 2
    core id         : 1
    cpu cores       : 2
    apicid          : 1
    initial apicid  : 1
    fpu             : yes
    fpu_exception   : yes
    cpuid level     : 5
    wp              : yes
    flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc pebs bts nopl pni dtes64
    monitor ds_cpl est cid cx16 xtpr
    bogomips        : 5999.84
    clflush size    : 64
    cache_alignment : 128
    address sizes   : 36 bits physical, 48 bits virtual
    
    run.sh script:
    Code:
    java -Xmx1024M -Xms1024M -jar craftbukkit.jar
    
    essentials gc:
    Code:
    >gc
    15:24:15 [INFO] max memory: 981 MB
    15:24:15 [INFO] allocated memory : 981 MB
    15:24:15 [INFO] free  memory : 738 MB
    15:24:15 [INFO] World "world": 625chunks,250entities
    15:24:15 [INFO] Nether "world_nether": 625chunks,190entities
    15:24:15 [INFO] World "world_the_end": 625chunks,18entities
    
    zip
  4. Offline

    andrewpo

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME

    Thanks for that information, I'm not entirely sure what is going on here so I'd wait for a bukkit team member to check this out; the information you've provided will assist them.

    This post has been edited 1 time. It was last edited by andrewpo Apr 14, 2012.
  5. Offline

    zipron

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Ok, I do hope a dev member reads this =)
  6. Offline

    andrewpo

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
  7. Offline

    zipron

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    ok well you tagged him now =)
  8. Offline

    farkros

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    god dammit i'm sick of this i've been having the same problem since i purchased my server about 3-4months ago
    i've searched everywheres and no will help or knows
  9. Offline

    Sayshal

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    bukkit.yml has an option to change the amount of ticks between mob spawning, you could decrease so they spawn more often.
  10. Offline

    zipron

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    It has it on "1" for me, still same problem... I would really like some adminds to look at this??
    @mbaxter
    @TnT
    @EvilSeph
    @ChrizC
    @Dinnerbone
  11. Offline

    cannontrodder

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I'm getting the exact same problems on this version of bukkit. Did anyone ever get to the bottom of it?
  12. Offline

    zipron

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    no admins ignore me (that's a joke btw),

    but no, really no fix at all

    This post has been edited 1 time. It was last edited by zipron May 18, 2012.
  13. Offline

    PhosphorusV

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I made an account to confirm this is a problem, and would love to know if a solution is being worked on!

    Thank you zipron for using science to bring this bug to light.
  14. Offline

    Fivestar

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Yes this is a problem for my server aswell. Difficulty is on 3.

    I have no clue whats going on, the spawner i build in multiplayer has gotten 0 mobs so far.. When it is suppose to get 40 per 3 minutse
  15. Offline

    hoppsan

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Server folder
    Bukkit.yml

    Code:
    spawn-limits:
      monsters: 125 // edit this ofc
      animals: 15
      water-animals: 5
    Save and restart

    I would love an option to make them spawn more often tho, but this will greatly increase mobs spawned.

    This post has been edited 3 times. It was last edited by hoppsan Jun 4, 2012.
  16. Offline

    BobGohd

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Would love to get an answer to this as well. Need more monsters!!

    This post has been edited 1 time. It was last edited by BobGohd Oct 5, 2012.
  17. Offline

    Ocllo

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Hey,

    I'm glad to hear I'm not the only one experiencing this. I've built at least half a dozen of these kinds of mob farms across different SMP servers with Bukkit, and they've all failed miserably. I get something like 1 group of monsters spawned for every 10 minutes with my 5-story, 1024-spawnable-block setup right now. Of course, these designs work absolutely fine in SSP.

    This is something I've seen for as long as I've played Minecraft on SMP, and it's particularly frustrating since quite a bit of time and effort goes into making these huge monolithic grinders. Not only that, but it's the only realistic way of farming gunpowder en masse.

    I've heard many explanations over the past year about what causes this. People used to say that "ghost entities" would be formed when the server spawned monsters and couldn't properly de-spawn them if the server's view-distance was set below 10. I haven't noticed a difference, though.

    Some people (including a couple of prominent YouTubers, such as Docm77) mention that you should build an "antenna" above your spawner in SMP (see: here), and that it may drastically improve mob spawning rates. Again, I haven't noticed a difference with this.

    I really hope someone - hopefully a dev - can clear this up. It would be nice to actually have working mob spawning mechanics in SMP for once.

    This post has been edited 2 times. It was last edited by resba Dec 12, 2012.
  18. Offline

    zipron

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Actuaklly, mobspawning works like a charm since 1.3.
  19. Offline

    LordDWT

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I have the same problem. Version 1.4.6
  20. Offline

    zipron

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    unless you use plugins, this is not possible. What is possible is that you just haven't cleared out enough caves, spawning algorithms have been changed a lot since 1.0.

    zip
  21. Offline

    mroy008

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I am using 1.4.5 and i have it since 1.2.
    I lit up ALL the caves and it's not the problem.
    If i restart the server it spawns mobs fine for about 30 seconds and then it just stops.
    I don't know what is going on but i really want my mob trap to work!

    This post has been edited 1 time. It was last edited by TnT Jan 3, 2013.
  22. Offline

    zipron

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    try a flatland world covered in slabs, create your mob spawner in there and put it on your server and try it, if it works fine, it means that your server settings are just fine and it's just not well lit.
  23. Offline

    frdmn

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Next thing, try with an "empty" bukkit. I mean, download the latest dev-.jar in another directory, set the necessary onfiguration and start it. Is your problem still existant?
  24. Offline

    mroy008

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I tried the superflat with slabs and it worked fine.
    I don't know what's going on in my survival world but after a few minutes from the server boot it stops spawning mobs completely. I checked the entity count and it was 1.
    Same thing with my enderman farm. When o go there it spawns endermen normally and after a few minutes it stops spawning them and the entity count drops to 1 until i restart the server.

    This post has been edited 1 time. It was last edited by NuclearW Jan 5, 2013.
  25. Offline

    mroy008

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Okay, i tried frdmn's tip and no mobs were spawning after a minute or two, just like in the bukkit that i always use.
    it seems like the problem is with the world itself. One of the wierdest things i have ever saw.

    This post has been edited 1 time. It was last edited by NuclearW Jan 5, 2013.
  26. Offline

    zipron

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    too bad, no idea what's causing that, but definitely it's not bukkit
  27. Offline

    mroy008

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Well thanks anyway,
    if i'll figure it out i'll tell you, and i hope it will be soon...
  28. Offline

    Ellediem

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    We're having the same issue on our 1.4.6 server.
  29. Offline

    Sniggel

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Had this problem for "forever" too. I think since 1.2 I havent really ever got rid of it. All different mob farms have the same problem. It spawns fine at the start but after a while the spawn starts to drop slowly until it doesnt spawn at all.
    Right now I have a mob farm at Y = 210 with the same problem. If I do //butcher 140 I get about 100 mobs the first times. Then If I wait the butcher will kill less each time until mobs stop spawning altogether.

    I just did a /butcher and forgot to put the radius 140 and got the message 1087 mobs killed. Which is weird since thats way over of the mob cap and those mobs that are out of the 140 range should despawn by themselves already. After that Mobs started spawning yet again.

    Ok. I am testing out this new thing as I am writing this post. I might be on to something...
    Yes! //butcher (without range defined) definately resets the spawn but the weird thing is how many mobs it kills and that it supposedly kills mobs that are outside of the spawn range. About 800-1000 mobs are common. If I repeat the command I can within 15 seconds butcher another 210 or so mobs (still over the mob cap) but if I do //butcher 140 (15s after //butcher) I get about 45 which is about the amount of mobs within my current mob farm.
    So it would seem that there are ghost entities being spawned "outside" 140 range? I will try to increase the range slowly and see just how far out they are...
    So I did a //butcher 140 until mobs stopped spawning and then I increased the range to:
    150 - 0 mobs killed
    160 - 0 mobs killed
    170 - 36 mobs killed - hmmm (repeat this distance until 0 is reached...)
    180 - 100 mobs killed - (repeat this distance until 0 is reached...)
    190 - 132 mobs killed - (repeat this distance until 0 is reached, takes a lot longer than 180)
    200 - 161 mobs killed - (repeat this distance until 0 is reached, takes a little bit longer than 190)
    210 - 307 mobs killed - (repeat this distance until 0 is reached, takes a looong time)
    220 - 451 mobs killed - (repeat this to see if the mob spawn decrease over time, waiting for 0 takes too long now :p) - It seems the drop in spawn here isnt as prevalent as on the others. If I do one //butcher 220 every minute I get about 300 kills each time
    230 - 697 mobs killed - 1 //butcher 230 each minute produces about the same amount of kills
    240 - 835 mobs killed - 683 next minute - 681 next minute (stable at 680-ish)
    250 - 689 mobs killed - 701 next minute (seem stable right from the start)
    275 - 681 mobs killed
    300 - 686 mobs killed - Really seems to be a cap at 680-ish mobs killed each minute. Gonna try //butcher (all) next minute...
    /butcher - 686 mobs killed - Yup!

    Ok. Now I admit I am a bit tired so I am not sure I explained what I just did in words that can be understood :p
    But i will explain what I think now:

    The distance at which you can kill 680-ish mobs by waiting 1 minute between //butchers, is the distance where mobs seem to spawn (which seems to be higher than I thought, has this been changed?). So lets find what distance that is. From my earlier butcherings it seems to be 240. Lets check!
    //butcher 240 with 1 minute interval - 956 at start - after 1 minute - 867 after 2 minutes - 855 after 3 minutes - 835 after 4 minutes (wtf more kills from "240" than "all"? I am confused, will try //butcher all again..)
    //butcher at 5th minute - 1210 mobs killed - 978 mobs killed at 6th minute - 990 mobs killed at 7th minute (trying //butcher 240 again)
    //butcher 240 at 8th minute - 942 mobs killed.

    Ok. I guess i am too tired to think clearly now. Will try investigating tomorrow again and post results here. Hopefully in a more organized manner...
  30. Offline

    Sniggel

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Ok. Now I have had some sleep. I will do a series of tests on a flat world at night. First test is as follows (30s interval between butcher):
    //butcher (resetting)
    //butcher, //butcher
    //butcher 500, //butcher 500
    //butcher 400, //butcher 400
    //butcher 300, //butcher 300
    //butcher 200, //butcher 200
    //butcher 100, //butcher 100, //butcher 100, //butcher 100

    Results:
    Reset -> 149
    All -> 147 - 148
    500 -> 148 - 150
    400 -> 147 - 150
    300 -> 148 - 149
    200 -> 150 - 149
    100 -> 90 - 87 - 78 - 75

    It worked as "normal". All distances killed an amount of mobs that corresponds to the current cap (130). Except for the distance 100, which is fine!
    I will try the same setup on the regular server in my mob farm (130 blocks above ground) where I was yesterday...

    Reset -> 452
    All -> 113 - 136
    500 -> 125 - 99
    400 -> 118 - 138
    300 -> 151 - 119
    200 -> 95 - 107
    100 -> 114 - 96
    There is a big variance in the amount of mobs spawned in 30s so its hard to see where the numbers start falling.

    Ill do another test. I start with a /time set 14000 (as I have done on the others) then ill reset spawn (//butcher) I try one distance 2 times (30s in between) and instantly after the second time Ill do a //butcher. If there is a big number on the last butcher then its a sign that mobs have been building up outside the chosen distance during the test.
    First test - 300
    time 14000 + reset -> 263
    300 -> 97 - 111
    Instantly followed by reset -> 25 (not very high)

    Second test - 200
    time 14000 + reset -> 232
    200 -> 124 - 137
    Instantly followed by reset -> 13 (not very high)

    Third test - 100 (expecting high number at end)
    time 14000 + reset -> 233
    100 -> 105 - 139
    Instantly followed by reset -> 29 (not very high)
    Hmm weird. It behaves like there isnt a problem. Was expecting a buildup of mobs outside the 100 range.
    Ill do a series of butchers at 100 to see if the killing declines over time (as it did yesterday)

    time 14000 + reset -> 238
    100 -> 140 - 87 - 126 - 111 - 123 - 120 - 130
    Instantly followed by reset -> 42 (somewhat high?)

    I cant see a decline in 3 minutes and 30 seconds. So what is different from yesterday?
    1. The server is restarted
    2. I have been in the same spot all along

    Does the server keep track of where mobs have spawned? This time it seems no mobs (or very little) have spawned outside the mob farm.
    Maybe if you derp around the world before going to the mob farm, the server retains a memory of where mobs have spawned and allows mobs to continue to spawn there, despite it being outside the range.
    If this is true. Then If I fly around the server, revealing tons of chunks, then get back to the mob farm again. I should see this declining effect more clearly. Ill try that out!

    Derpflying... (and then getting back to original position in mob farm)
    time 14000 + reset -> 300
    100 -> 98 - 106 - 113 - 130 - 115 - 140 - 130
    Instantly followed by reset -> 166 mobs!

    Ok I didnt notice a decline but a much larger buildup outside the 100 range.
    So it seems that the more explored the server is (since restart) the larger the spawn area is (or something :p).
    Why is that?

    This post has been edited 6 times. It was last edited by Sniggel Jan 14, 2013.
Thread Status:
Not open for further replies.

Share This Page