Server with Hamachi

Discussion in 'Bukkit Help' started by Crafter_Peter, Nov 17, 2012.

  1. Offline

    Crafter_Peter

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Hello guys I was just wondering if someone could help with the issue I am having. Here is the problem.

    I host my bukkit server with hamachi and I changed the server file ip to my hamachi ip and it says that its loaded and it works for but when my friend adds the ip to his minecraft it says cant reach server and yes he is in my hamachi channel. Remember it will show up for me.

    I'm hopeing you guys can help me.

    ~Crafter-Peter

    This post has been edited 1 time. It was last edited by TnT Nov 17, 2012.
  2. Offline

    lokpique

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Leave the server ip blank. Works fine on every hamachi server i've ever had to set up.

    On a side note... you are better off learning how to just port forward and stop using hamachi. Long story, but it's not a safe application.
  3. Offline

    Crafter_Peter

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    See we have tried this but when I type ipconfig in the cmd and it says ipconfig is not recognized as an internal or external command, operable program or batch file.
  4. Offline

    MysteryManX

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Or you can not be a noob and not use Hamachi? :3
  5. Offline

    lokpique

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    You did read the second sentence I wrote, right? Sometimes hamachi is the only option... for instance... if you play from a dorm or a school that has a firewall blocking standard methods to connect.

    I used to have to use it to play from work. The company firewall blocked the native connection.
  6. Offline

    Crafter_Peter

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Any ideas on the config problem also it didnt work
  7. Offline

    lokpique

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    What is preventing you from skipping hamachi and just opening the port on your router? It's by far a safer option that way.
  8. Offline

    Waterflames

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Anytime you have a problem with a command not being recognized in cmd, try running cmd as administrator.
    It sets the cd to c:/Windows/System32, where most of these executables are located.

    This post has been edited 1 time. It was last edited by Waterflames Nov 17, 2012.
  9. Offline

    lokpique

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Not sure what thread you meant to reply to... but it certainly was not this one. Completely unrelated to his issue.
  10. Offline

    Waterflames

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    See third comment.
  11. Offline

    Crafter_Peter

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Also it's a windows 8 computer if this makes any difference
  12. Offline

    lokpique

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    You don't have to be running as an administrator to see ipconfig, so that isn't the problem anyways.
  13. Offline

    Crafter_Peter

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Also it didn't work when i ran it as administration
  14. Offline

    Waterflames

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Thats not what I said. I said running cmd as administrator fixed the problem, because it sets the current directory to the system23 folder. Of course you could just cd to it, but running as admin is faster.

    Ontopic: Look up port forwarding for your router and try to do it without Hamachi. Hamachi has never worked for me.
  15. Offline

    Crafter_Peter

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I have and i default gateway is 192.168.1.1 and it wont open it just searches it... Also windows 8 i never had the problem on windows 7
  16. Offline

    lokpique

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Not too familiar with windows 8, but this screams that there is something with the windows firewall you need to configure.

Share This Page